summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2021-11-10 18:31:56 +0100
committerDaniel Peukert2021-11-10 18:31:56 +0100
commit100073902e1981c0e336c4ca13a9f63459601c83 (patch)
treeed195cc358c79e2866ed1eb4c6905898a53294df /PKGBUILD
parent6be95297f702a3a0f935f9e7fb33e5b33cdeb7cb (diff)
downloadaur-100073902e1981c0e336c4ca13a9f63459601c83.tar.gz
Update ocaml-ocplib-endian to 1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78ca28015132..146f0289afb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
-pkgver='1.1'
-pkgrel='4'
+pkgver='1.2'
+pkgrel='1'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/OCamlPro/$_projectname"
license=('custom:LGPL2.1 with linking exception')
-depends=('ocaml>=4.02.3')
+depends=('ocaml>=4.03.0')
makedepends=('cppo' 'dune>=1.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('455b3dae8622eb9c4e99a52b8a6004b40294ab9112c50dad2ab1bf10eec1c563')
+sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- dune build -p "$_projectname" --verbose
+ dune build --release --verbose
}
check() {
cd "$srcdir/$_sourcedirectory/"
- dune runtest -p "$_projectname" --verbose
+ dune runtest --release --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
install -dm755 "$pkgdir/usr/share/doc/$pkgname"
mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"