summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-05 01:40:30 +0200
committerDaniel Peukert2020-04-05 01:40:30 +0200
commit54d14aa7dfdac921eb2fa948950751373c9ce3da (patch)
tree0cee0bd8912c3a1efc64eb686630ea23bf7ebc2e /PKGBUILD
parent1633b46e872abbef37f376196cd34f679fc372a7 (diff)
downloadaur-54d14aa7dfdac921eb2fa948950751373c9ce3da.tar.gz
Updated ocaml-ocplib-endian to 1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e7bf6e7621f..40dc52a5ceb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,40 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
-pkgver='1.0'
-pkgrel='3'
+pkgver='1.1'
+pkgrel='1'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/OCamlPro/$_projectname"
license=('custom:LGPL2.1 with linking exception')
-depends=('ocaml')
-makedepends=('cppo' 'ocamlbuild' 'ocaml-findlib')
+depends=('ocaml>=4.02.3')
+makedepends=('cppo' 'dune>=1.0.0')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('76f268e1aff8dbac8b6a0ca9473f90255da35f15b0fcaf26a840cb6f73029243')
+sha256sums=('455b3dae8622eb9c4e99a52b8a6004b40294ab9112c50dad2ab1bf10eec1c563')
_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"
- ./configure --disable-debug
- make build
+ dune build -p "$_projectname" --verbose
+}
+
+check() {
+ cd "$srcdir/$_sourcedirectory/"
+ dune runtest -p "$_projectname" --verbose
}
package() {
cd "$srcdir/$_sourcedirectory/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm755 "$OCAMLFIND_DESTDIR"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
+ rm -r "$pkgdir/usr/doc/"
- make install
+ install -Dm644 'COPYING.txt' "$pkgdir/usr/share/doc/$pkgname/COPYING.txt"
- install -Dm644 'README.md' "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -Dm644 'COPYING.txt' "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "/usr/share/doc/$pkgname/COPYING.txt" "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"
}