summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2023-12-10 11:50:29 +0100
committerDaniel Peukert2023-12-10 11:50:29 +0100
commitccd0e09bbcab76770516fcb4cb2d781234770d93 (patch)
tree3b2e1bd61d00482466ca2367a7599a5c42bc57f7 /PKGBUILD
parentdc73ffd6539ab1a275ee75c564785dc23b45fdfb (diff)
downloadaur-ccd0e09bbcab76770516fcb4cb2d781234770d93.tar.gz
Remove unnecessary ocaml-ocplib-endian patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6e95f1f9af8..842c590eadd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,19 @@
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
pkgver='1.2'
-pkgrel='5'
+pkgrel='6'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
-# If you're running on aarch64, you have to add it to the arch array of the cppo AUR dependency
arch=('x86_64' 'aarch64')
url="https://github.com/OCamlPro/$_projectname"
license=('custom:LGPL2.1 with linking exception')
depends=('ocaml>=4.03.0')
makedepends=('cppo' 'dune>=1.0.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- "$pkgname-$pkgver-$pkgrel-remove-bytes-dep.diff::$url/pull/26.diff"
-)
-sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85'
- '6199b7032bb3939513de1376966c595fc47e8204f2ba96d6909897378ed18f88e39d81bdabb09c4669c092eacdb8c600fccde733d61677890093b2a50bb90bf0')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
-
- # Make sure we don't directly depend on bytes, as that stopped working in ocaml 5.0 (https://github.com/OCamlPro/ocplib-endian/pull/26)
- patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-remove-bytes-dep.diff"
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose
@@ -42,7 +30,9 @@ package() {
cd "$srcdir/$_sourcedirectory/"
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
- install -Dm644 'COPYING.txt' "$pkgdir/usr/share/doc/$pkgname/COPYING.txt"
+ for _folder in "$pkgdir/usr/share/doc/"*; do
+ mv "$_folder" "$pkgdir/usr/share/doc/ocaml-$(basename "$_folder")"
+ done
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/COPYING.txt" "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"