summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-03-15 00:51:39 +0100
committerDaniel Peukert2020-03-15 00:51:39 +0100
commitf7ab47734c3a0be733cae82a61e3d9e7e2168f13 (patch)
treef56ab1ec583694ab302b57f0dbb65175ad55a7ca /PKGBUILD
parent9abcf38fcc997cfc841a8ddba594348d0272d75b (diff)
downloadaur-f7ab47734c3a0be733cae82a61e3d9e7e2168f13.tar.gz
Added ocaml-lwt and dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 26 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcb40379d72c..c5bb31438eb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-
-pkgname=ocaml-ocplib-endian
-pkgver=1.0
-pkgrel=1
-pkgdesc="Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays"
-arch=('x86_64')
-url="https://www.typerex.org/ocplib-endian.html"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+_projectname='ocplib-endian'
+pkgname="ocaml-$_projectname"
+pkgver='1.0'
+pkgrel='2'
+pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/OCamlPro/$_projectname"
license=('custom:LGPL2.1 with linking exception')
depends=('ocaml')
-makedepends=('ocaml-findlib' 'ocamlbuild' 'cppo')
-source=("https://github.com/OCamlPro/ocplib-endian/archive/${pkgver}.tar.gz")
-sha512sums=('a08fd58ec5e72510c40e8b75e0ee8327ee658f479e45dd4632bc04e3907d04aaa3684df3b993ab63fc2a6c1f1a4fb32784e9b5258730d3b89a716300522d8d7f')
+makedepends=('cppo' 'ocamlbuild' 'ocaml-findlib')
+options=('!strip')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('76f268e1aff8dbac8b6a0ca9473f90255da35f15b0fcaf26a840cb6f73029243')
-build() {
- cd "${srcdir}/ocplib-endian-${pkgver}"
+_sourcedirectory="$_projectname-$pkgver"
- ./configure --disable-debug
- make build
+build() {
+ cd "$srcdir/$_sourcedirectory/"
+ ./configure --disable-debug
+ make build
}
-
package() {
- cd "${srcdir}/ocplib-endian-${pkgver}"
+ cd "$srcdir/$_sourcedirectory/"
+
+ export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
+ install -dm755 "$OCAMLFIND_DESTDIR"
+
+ make install
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- install -dm755 "${OCAMLFIND_DESTDIR}"
- make install
- install -Dm644 "COPYING.txt" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.txt"
+ install -Dm644 'README.md' "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 'COPYING.txt' "$pkgdir/usr/share/licenses/$pkgname/COPYING.txt"
}