summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2022-11-30 13:27:51 +1100
committerRod Kay2022-11-30 13:28:46 +1100
commitf631325aab82642863c90af995504d4ac6732fdd (patch)
tree296ba8dd0aa1996d4434f814a72b8c2e861a4857 /PKGBUILD
parentea29fb9fa81eaa7100c979a6a9aa2c3db91259d7 (diff)
downloadaur-f631325aab82642863c90af995504d4ac6732fdd.tar.gz
Update build() for latest version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9f6ef1be882..4f19103266de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ocaml-ocplib-simplex-git
-pkgver=0.4.r4.gd52771f
+pkgver=0.5.r0.g9b0944c
pkgrel=1
pkgdesc='simplex algorithm implementation for solving systems of linear inequalities and optimizing linear objective functions'
@@ -7,25 +7,30 @@ url='https://github.com/OCamlPro-Iguernlala/ocplib-simplex'
arch=('i686' 'x86_64')
license=('LGPL')
-depends=('ocaml')
-makedepends=('ocaml-findlib' 'git')
+depends=('ocaml' 'ocaml-num' 'ocaml-logs')
+makedepends=('ocaml-findlib' 'git' 'dune')
provides=('ocaml-ocplib-simplex')
conflicts=('ocaml-ocplib-simplex')
-source=('git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex')
+source=('git+https://github.com/OCamlPro-Iguernlala/ocplib-simplex'
+ 'dirs.patch')
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '8640fee9d5f773a79e992c564555b0448763e8a4d15060571984df7f754afb50')
pkgver() {
cd ocplib-simplex
git describe --long --tags | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/-/./g'
}
+prepare() {
+ cd ocplib-simplex
+ patch -p1 < ../dirs.patch
+}
+
build() {
cd ocplib-simplex
- autoreconf -fi
- ./configure --prefix=/usr
make
}