summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-11 20:04:59 -0600
committerBrian Bidulock2015-07-11 20:04:59 -0600
commitfa1ffe7260f11db37637b07437aad4c42bbbbaf7 (patch)
treeb93f62696d015f032d93fdbfce5c4340a25ddd58 /PKGBUILD
downloadaur-fa1ffe7260f11db37637b07437aad4c42bbbbaf7.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233e2fe7511c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Charles E. Hawkins <charlesthehawk at yahoo dot com>
+
+pkgname=ocaml-otk
+pkgver=0.6.1
+pkgrel=2
+pkgdesc="A bleeding edge fork of lablTk to implement new features of Tk."
+arch=('i686' 'x86_64')
+url="http://forge.ocamlcore.org/projects/otk"
+license=('LGPL')
+depends=('tcl' 'tk' 'ocaml>=4.0')
+source=("http://forge.ocamlcore.org/frs/download.php/1515/otk-$pkgver.tar.gz")
+md5sums=('cc1691a5a524f1c44b65edce5adc55be')
+
+build() {
+ cd "$srcdir/otk"
+ make
+ make opt
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/ocaml/stublibs"
+ mkdir "$pkgdir/usr/bin"
+ cd "$srcdir/otk"
+ make BINDIR="$pkgdir/usr/bin" STUBLIBDIR="$pkgdir/usr/lib/ocaml/stublibs" INSTALLDIR="$pkgdir/usr/lib/ocaml/otk" install
+ make BINDIR="$pkgdir/usr/bin" STUBLIBDIR="$pkgdir/usr/lib/ocaml/stublibs" INSTALLDIR="$pkgdir/usr/lib/ocaml/otk" installopt
+ install -Dm 644 compiler/copyright "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}