summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Fung2021-12-20 02:30:19 -0800
committerEric Fung2021-12-20 02:30:19 -0800
commitca3778c852845263b807d005cd1c6cf02c1e21c5 (patch)
tree49976b91a01136c9cde9e553d4a755f224811047 /PKGBUILD
parentbfdf226f104a42d40991216c8fd6420c1be0d488 (diff)
downloadaur-ca3778c852845263b807d005cd1c6cf02c1e21c5.tar.gz
Updated build() and depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbd2fd3843d1..0e3782c9fd02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,14 @@
pkgname=ocaml-pcre
pkgver=7.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Perl compatible regular expressions for OCaml"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('x86_64')
url="http://mmottl.github.io/pcre-ocaml"
license=('custom:LGPL2.1 with linking exception')
-depends=('ocaml' 'pcre')
-makedepends=('dune' 'ocaml-base')
+depends=('ocaml' 'ocaml-base' 'pcre')
+makedepends=('dune')
+provides=('pcre-ocaml')
replaces=('pcre-ocaml')
conflicts=('pcre-ocaml')
options=('!strip' 'staticlibs')
@@ -23,7 +24,7 @@ sha256sums=('671142f40b6d86171cbc067253faadf903019161d57488bd0fb6c5456c2cbd1a')
build() {
cd "${srcdir}/pcre-${pkgver}"
- dune build
+ dune build @install
}
package() {