summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2016-02-06 03:06:58 +0100
committerJ5lx2016-02-06 03:06:58 +0100
commit3d8063b449970b41df2677535d85b37f96f4acd6 (patch)
treee00acbd0689b3368b55a43351f145e0bb8503b32 /PKGBUILD
downloadaur-3d8063b449970b41df2677535d85b37f96f4acd6.tar.gz
3.0-1: Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8224f085c164
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+_pkgname=ppx_deriving
+pkgname=ocaml-${_pkgname}
+pkgver=3.0
+pkgrel=1
+pkgdesc="Type-driven code generation for OCaml >=4.02"
+arch=('i686' 'x86_64')
+url="https://github.com/whitequark/ppx_deriving"
+license=('MIT')
+depends=('ocaml' 'ocaml-ppx_tools')
+makedepends=('ocaml-findlib')
+source=("https://github.com/whitequark/${_pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('32907f30e2b3439230fefe3ca320d11f')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ export OCAMLPATH="$(ocamlc -where):${pkgdir}$(ocamlc -where)"
+ export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
+ mkdir -p "${OCAMLFIND_DESTDIR}"
+
+ make install
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}