summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-11-26 09:53:40 +0100
committerDaniel Peukert2020-11-26 09:53:40 +0100
commit8b573789a72b32672ac9e03bcb9c406e765b9284 (patch)
tree444e5255cc908a76644deed0bcacf507986fb20d /PKGBUILD
parentd8f81c993460331323748dd480c18c4ca399c0e1 (diff)
downloadaur-8b573789a72b32672ac9e03bcb9c406e765b9284.tar.gz
Updated ocaml-ppx_deriving to 5.2 (again)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1eb601e3c19a..c78ef85cc999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
_projectname='ppx_deriving'
pkgname="ocaml-$_projectname"
-pkgver='5.3'
-_commit='acb48690d73d15c6bf999087ed251334ecd1cb33'
-pkgrel='2'
+pkgver='5.2'
+pkgrel='1'
+epoch='1'
pkgdesc='Type-driven code generation for OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
license=('MIT')
-depends=('ocaml>=4.05.0' 'ocaml-ppx_derivers' 'ocaml-ppxlib>=0.18.0' 'ocaml-result')
+depends=('ocaml>=4.05.0' 'ocaml-findlib' 'ocaml-ppx_derivers' 'ocaml-ppxlib>=0.20.0' 'ocaml-result')
makedepends=('cppo' 'dune>=1.6.3')
checkdepends=('ocaml-ounit')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$_commit.tar.gz")
-sha256sums=('37300e0bd22ccd7d51e918b09579d66ed36f49a6b79a6c2f901d03c0079fbc23')
+source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('516bb879a638928b594feb74a87b7c433abd613a2263c40f0db95dbace73310e')
-_sourcedirectory="$_projectname-$_commit"
+_sourcedirectory="$_projectname-$pkgver"
build() {
cd "$srcdir/$_sourcedirectory/"