summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 14:25:52 +0200
committerJakob Gahde2016-07-29 14:25:52 +0200
commit4ed27354d8e0725fb7de60b37534edbfb666644b (patch)
treef960a1d83eb26a2650cd78adf9657fcea0b33d61 /PKGBUILD
parent56471e676469958a77551f54418735b8e610444d (diff)
downloadaur-4ed27354d8e0725fb7de60b37534edbfb666644b.tar.gz
ocaml-ppx_expect 113.33.03-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 872163d38449..a618800dfb57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_expect
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Cram like framework for OCaml"
url="https://github.com/janestreet/ppx_expect"
-depends=('ocaml' 'ocaml-ppx_assert' 'ocaml-ppx_compare' 'ocaml-ppx_core' 'ocaml-ppx_custom_printf' 'ocaml-ppx_driver' 'ocaml-ppx_fields_conv' 'ocaml-ppx_inline_test' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_sexp_value' 'ocaml-ppx_tools' 'ocaml-ppx_variants_conv' 'ocaml-re' 'ocaml-sexplib' 'ocaml-variantslib')
-makedepends=('ocaml-findlib' 'opam')
+depends=('ocaml' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_compare' 'ocaml-ppx_core' 'ocaml-ppx_custom_printf' 'ocaml-ppx_driver' 'ocaml-ppx_fields_conv' 'ocaml-ppx_here' 'ocaml-ppx_inline_test' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools' 'ocaml-ppx_variants_conv' 'ocaml-re' 'ocaml-sexplib' 'ocaml-variantslib')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('fa7191448707d0723e15c13a29b93315'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('ceca13eb18037e611717029d16ca48d7'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ '613b386c3d58edc66678e22d984f62c8')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {