summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2019-05-15 11:22:42 +0200
committerJakob Gahde2019-05-15 11:22:42 +0200
commitdff918943e37ae13bf8ed17ff8e9b348cf91d0c0 (patch)
tree9326a5d64326bf41b518a4dd9154bf8c0f4b5061 /PKGBUILD
parent3dad25fc80037041812e94855f99c64e7d866834 (diff)
downloadaur-dff918943e37ae13bf8ed17ff8e9b348cf91d0c0.tar.gz
ocaml-ppx_hash 0.12.0-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 024dca6d76c5..ce12fe824a8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_hash
-pkgver=0.11.1
+pkgver=0.12.0
pkgrel=1
pkgdesc="A ppx rewriter that generates hash functions from type expressions and definitions"
arch=('x86_64')
url='https://github.com/janestreet/ppx_hash'
-license=('Apache')
-depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_sexp_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+license=('MIT')
+depends=('ocaml' 'ocaml-base' 'ocaml-ppx_compare' 'ocaml-ppx_sexp_conv' 'ocaml-ppxlib')
makedepends=('dune')
options=('!strip')
source=("https://github.com/janestreet/ppx_hash/archive/v${pkgver}.tar.gz")
-md5sums=('48dfe890e195808ccdae0a7261bbb17d')
+sha512sums=('bc703cb88ec2ecfc3af8890bc231c3e93ae68caadb6917d2bc7b7f30ca210bfda559d94cd562d5ecaf8ac7178d9219499ffbdb1042d1c83d68646106546ef0ec')
build() {
cd "${srcdir}/ppx_hash-${pkgver}"
- jbuilder build
+ dune build
}
@@ -24,6 +24,7 @@ package() {
cd "${srcdir}/ppx_hash-${pkgver}"
mkdir -p "${pkgdir}$(ocamlfind printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
+ dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}