summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 13:45:05 +0200
committerJakob Gahde2016-07-29 13:45:05 +0200
commit388336a54819fad564b4c00ddde36f2d78932f81 (patch)
tree0e3e46a1270bdbb451be69097e6fc69aca7b664d /PKGBUILD
parentb9eaa3603ca97b65de5c535dd5a6aae841821024 (diff)
downloadaur-388336a54819fad564b4c00ddde36f2d78932f81.tar.gz
ocaml-ppx_inline_test 113.33.03-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f4f8d18d89e..33746f686ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_inline_test
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Syntax extension for writing in-line tests in ocaml code"
url="https://github.com/janestreet/ppx_inline_test"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('5d80120af94ba974670a0a28b1200160'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('6abbbcbe8aefbb9d30721e252cd5c7f4'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ 'e4d9f81044407306bb88373ae2e12932')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {