summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2018-06-28 19:43:45 +0200
committerJakob Gahde2018-06-28 19:43:45 +0200
commit9038302869fb962f3d3c5aa1d69f80fc15a8fce0 (patch)
treeb12357e41e934a8b03cdef312c7b40b8ca5e92e4 /PKGBUILD
parente5aae06f4af58219f30d128d07dda06c4bd5de1a (diff)
downloadaur-9038302869fb962f3d3c5aa1d69f80fc15a8fce0.tar.gz
ocaml-ppx_jane 1:0.11.0-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fbd9c749310..c2c67110f3ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_jane
-pkgver=113.33.03
+pkgver=0.11.0
pkgrel=1
+epoch=1
pkgdesc="Standard Jane Street ppx rewriters"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/ppx_jane"
license=('Apache')
-depends=('ocaml' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_bin_prot' 'ocaml-ppx_compare' 'ocaml-ppx_custom_printf' 'ocaml-ppx_driver' 'ocaml-ppx_enumerate' 'ocaml-ppx_expect' 'ocaml-ppx_fail' 'ocaml-ppx_fields_conv' 'ocaml-ppx_here' 'ocaml-ppx_inline_test' 'ocaml-ppx_let' 'ocaml-ppx_pipebang' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_sexp_message' 'ocaml-ppx_sexp_value' 'ocaml-ppx_typerep_conv' 'ocaml-ppx_variants_conv')
-makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
+depends=('ocaml' 'ocaml-ppx_assert' 'ocaml-ppx_base' 'ocaml-ppx_bench' 'ocaml-ppx_bin_prot' 'ocaml-ppx_custom_printf' 'ocaml-ppx_expect' 'ocaml-ppx_fail' 'ocaml-ppx_fields_conv' 'ocaml-ppx_here' 'ocaml-ppx_inline_test' 'ocaml-ppx_let' 'ocaml-ppx_optcomp' 'ocaml-ppx_optional' 'ocaml-ppx_pipebang' 'ocaml-ppx_sexp_message' 'ocaml-ppx_sexp_value' 'ocaml-ppx_typerep_conv' 'ocaml-ppx_variants_conv' 'ocaml-migrate-parsetree' 'ocaml-ppxlib')
+makedepends=('dune')
options=('!strip')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-md5sums=('14e4dea12340e225e7b413b6c3b62a37'
- '7f0a951f1ac87385272ea7a6dd58762a')
-
-prepare() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
- patch -Np1 < "${srcdir}/libdir.patch"
-}
+source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/ppx_jane-v${pkgver}.tar.gz")
+md5sums=('11da0871ae3841fb6710ec6471ce6b92')
build() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_jane-v${pkgver}"
- ./configure --prefix=/usr
- make
+ jbuilder build
}
package() {
- cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+ cd "${srcdir}/ppx_jane-v${pkgver}"
- make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
+ install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
+ jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}