summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 14:11:45 +0200
committerJakob Gahde2016-07-29 14:11:45 +0200
commit24f80e3c4a9ca805c04300749c79f63fa17b5156 (patch)
treeec8cc750bbaadf98a9a289864fae549a6c6a1a88 /PKGBUILD
parentc5d3c8ab2f0e6c35b124ae0aba1b80dd4464a8e8 (diff)
downloadaur-24f80e3c4a9ca805c04300749c79f63fa17b5156.tar.gz
ocaml-ppx_sexp_value 113.33.03-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48321e1abf96..087ea0d6e6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-ppx_sexp_value
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="A ppx rewriter that simplifies building s-expressions from ocaml values"
url="https://github.com/janestreet/ppx_sexp_value"
depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
-makedepends=('ocaml-findlib' 'opam')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
- "libdir.patch")
-options=('!strip')
-md5sums=('8a16a9b1f74a59e8a1fa11d65ff39842'
- '7f0a951f1ac87385272ea7a6dd58762a')
+ "libdir.patch"
+ "exedir.patch")
+options=('!strip' '!emptydirs')
+md5sums=('0582ea3bc8edddc6bb8731514059da84'
+ '7f0a951f1ac87385272ea7a6dd58762a'
+ 'e155286965bf825c87fbeca63fa53e01')
prepare() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
patch -Np1 < "${srcdir}/libdir.patch"
+ patch -Np1 < "${srcdir}/exedir.patch"
}
build() {