summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2016-02-06 03:38:37 +0100
committerJ5lx2016-02-06 03:38:37 +0100
commitc5d3c8ab2f0e6c35b124ae0aba1b80dd4464a8e8 (patch)
tree0e44197af8ac9fddedcc9af165cedf6e273c1fe9 /PKGBUILD
downloadaur-c5d3c8ab2f0e6c35b124ae0aba1b80dd4464a8e8.tar.gz
113.24.00-1: Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48321e1abf96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=ocaml-ppx_sexp_value
+pkgver=113.24.00
+pkgrel=1
+license=('Apache')
+arch=('i686' 'x86_64')
+pkgdesc="A ppx rewriter that simplifies building s-expressions from ocaml values"
+url="https://github.com/janestreet/ppx_sexp_value"
+depends=('ocaml' 'ocaml-ppx_core' 'ocaml-ppx_driver' 'ocaml-ppx_here' 'ocaml-ppx_sexp_conv' 'ocaml-ppx_tools')
+makedepends=('ocaml-findlib' 'opam')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+\.[0-9]+").tar.gz"
+ "libdir.patch")
+options=('!strip')
+md5sums=('8a16a9b1f74a59e8a1fa11d65ff39842'
+ '7f0a951f1ac87385272ea7a6dd58762a')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/libdir.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ make install PREFIX="${pkgdir}/usr" LIBDIR="${pkgdir}$(ocamlc -where)"
+}