summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMort Yao2018-05-19 00:17:18 +0200
committerMort Yao2018-05-19 00:17:18 +0200
commit7aef128e735163be0fbb9243724da2ed5a925fb9 (patch)
tree722f13a768ecb0ddb2ce30e52b29c35a98596951 /PKGBUILD
downloadaur-7aef128e735163be0fbb9243724da2ed5a925fb9.tar.gz
ocaml-ppxfind-git 20171213-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32a7dc6de28e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=ocaml-ppxfind-git
+pkgver=20171213
+pkgrel=1
+pkgdesc="ocamlfind ppx tool"
+arch=('x86_64')
+url='https://github.com/diml/ppxfind'
+license=('ISC')
+provides=('ocaml-ppxfind')
+makedepends=('ocamlbuild' 'ocaml-findlib')
+source=("${pkgname}::git://github.com/diml/ppxfind.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ destdir="$pkgdir/$(ocamlfind printconf destdir)"
+
+ cd "$pkgname"
+
+ mkdir -p "${pkgdir}"/usr/bin/
+ cp _build/install/default/bin/ppxfind "${pkgdir}"/usr/bin/
+}