summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2019-11-30 19:18:20 +0100
committerAlad Wenter2019-11-30 19:18:20 +0100
commit2504e403ccbe45a791f5af43dae104a8a72d3e4e (patch)
treec88b1ca48bf108c562de4e3d315fc5ff91094484 /PKGBUILD
downloadaur-2504e403ccbe45a791f5af43dae104a8a72d3e4e.tar.gz
ocaml-psmt2-frontend: init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e2dcb5e4490
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=ocaml-psmt2-frontend
+_pkgname=psmt2-frontend
+pkgver=0.2
+pkgrel=1
+pkgdesc="A simple parser and type-checker for polomorphic extension of the SMT-LIB 2 language"
+arch=('x86_64')
+url="https://github.com/Coquera/psmt2-frontend"
+license=('Apache2')
+depends=('ocaml')
+makedepends=('ocaml' 'ocaml-menhir')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OCamlPro-Coquera/psmt2-frontend/archive/$pkgver.tar.gz")
+sha256sums=('59c25982fcdae1128dea6f260e76bbfd1dd4fe45b34aa168ae084281f4941303')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ autoconf
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/ocaml/psmt2-frontend"
+ make DESTDIR="$pkgdir/usr" LIBDIR="$pkgdir/usr/lib/ocaml" install
+}