summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Eklind2018-08-28 12:29:11 +0000
committerRobin Eklind2018-08-28 12:29:11 +0000
commitf0b4c76a530aae5d62a06184b33862c411a03053 (patch)
tree186e9493e547f7f24c6d8a8844f344fe5386fa46 /PKGBUILD
downloadaur-f0b4c76a530aae5d62a06184b33862c411a03053.tar.gz
Initial commit
Currently using mewpull until #3 is resolved.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f450898ef73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=psmt2-frontend-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="A simple parser and type-checker for polomorphic extension of the SMT-LIB 2 language"
+arch=('i686' 'x86_64')
+url="https://github.com/Coquera/psmt2-frontend"
+license=('Apache2')
+depends=('ocaml')
+makedepends=('ocaml' 'ocaml-menhir')
+options=(!strip staticlibs)
+
+
+# TODO: update from Coquera to mewpull when PR #4 is merged.
+_gitroot="https://github.com/Coquera/psmt2-frontend.git"
+_gitname="psmt2-frontend"
+
+build() {
+ cd "$srcdir"
+
+ if [ -d "$srcdir/$_gitname" ]; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+
+ cp -rf "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+
+ mkdir -p "$pkgdir/usr/lib/ocaml/psmt2-frontend"
+ make DESTDIR="$pkgdir/usr" LIBDIR="$pkgdir/usr/lib/ocaml" install
+}