summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2019-09-10 00:38:27 +0200
committerJakob Gahde2019-09-10 00:38:27 +0200
commit8a075bd388c95d1f8712e398d6bb872c2c8dbf65 (patch)
tree6e53bbd88ed6eacdd6e79dba2e758ef507f82fd4 /PKGBUILD
parente24a468e265193ccacb3323d82fc5717cca520df (diff)
downloadaur-8a075bd388c95d1f8712e398d6bb872c2c8dbf65.tar.gz
ocaml-sexplib 1:0.12.0-1: Update to new version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6facd5f7678e..703374df89c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,29 +6,30 @@
# Contributor: Sylvester Johansson <scj(at)archlinux(dot)us>
pkgname=ocaml-sexplib
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
epoch=1
pkgdesc="Library for serializing OCaml values to and from S-expressions"
arch=('i686' 'x86_64')
url="https://github.com/janestreet/sexplib"
-license=('Apache')
+license=('MIT' 'BSD')
depends=('ocaml' 'ocaml-parsexp' 'ocaml-sexplib0' 'ocaml-num')
makedepends=('dune')
options=('!strip')
source=("https://ocaml.janestreet.com/ocaml-core/v$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/sexplib-v${pkgver}.tar.gz")
-md5sums=('1d53d945914b6b9a380dc8923f19e9ae')
+sha512sums=('bd050e59f5269f15b3362891f98417c78bbe6e18c630488ac3df769dd70180beb4e1bbf55e32327fd2dec9a6041969bcaa4f9d16b9295e33cc82af1515404701')
build() {
cd "${srcdir}/sexplib-v${pkgver}"
- jbuilder build
+ dune build --profile release
}
package(){
cd "${srcdir}/sexplib-v${pkgver}"
- install -dm755 "${pkgdir}$(ocamlfind -printconf destdir)" "${pkgdir}/usr/share"
- jbuilder install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"
+ dune install --destdir "${pkgdir}"
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm644 "LICENSE-Tywith.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-Tywith.txt"
mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}