summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2016-02-06 02:25:21 +0100
committerJ5lx2016-02-06 02:25:21 +0100
commitbb1c2263b98fb86dc54a527ff857035116d5cc14 (patch)
tree1ae1da50253ca476981ebc31675ff02c9c28250b /PKGBUILD
parentdb4847d54441b0c0c298ea3ad9205f6751a059d0 (diff)
downloadaur-bb1c2263b98fb86dc54a527ff857035116d5cc14.tar.gz
113.24.00-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d7b23c93894..aaae02461458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,29 +6,35 @@
# Contributor: Sylvester Johansson <scj(at)archlinux(dot)us>
pkgname=ocaml-sexplib
-pkgver=113.00.00
+pkgver=113.24.00
pkgrel=1
pkgdesc="Library for serializing OCaml values to and from S-expressions"
arch=('i686' 'x86_64')
license=('Apache')
depends=('ocaml>=4.02.1')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'opam')
options=('!strip')
url="https://github.com/janestreet/sexplib"
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
-md5sums=('642c795001cc3df4631e678852c806c8')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
+ "libdir.patch")
+md5sums=('f4f1e679187842c22db482dec5e11f36'
+ '7f0a951f1ac87385272ea7a6dd58762a')
+
+prepare() {
+ cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
+
+ patch -Np1 < "${srcdir}/libdir.patch"
+}
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- ./configure --prefix /usr --destdir $pkgdir
+ ./configure --prefix /usr
make
}
package(){
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
- export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
- mkdir -p "${OCAMLFIND_DESTDIR}"
- make install
+ make install LIBDIR="${pkgdir}$(ocamlc -where)"
}