summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Gahde2016-07-29 15:53:39 +0200
committerJakob Gahde2016-07-29 15:53:39 +0200
commit7ef8aca317a3bc72a7bdab43f5e66b9f83001d10 (patch)
tree89b61f234b9bd18b4599f58aeb3631fdb837677e /PKGBUILD
parente75c8b875e5759ec13f5c7e5bde160a8f7b5ccee (diff)
downloadaur-7ef8aca317a3bc72a7bdab43f5e66b9f83001d10.tar.gz
ocaml-textutils 113.33.03-1: New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 552b2402759d..9ffca56e5ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=ocaml-textutils
-pkgver=113.24.00
+pkgver=113.33.03
pkgrel=1
license=('Apache')
arch=('i686' 'x86_64')
pkgdesc="Text output utilities"
url="https://github.com/janestreet/textutils"
depends=('ocaml' 'ocaml-bin_prot' 'ocaml-core' 'ocaml-fieldslib' 'ocaml-ppx_assert' 'ocaml-ppx_bench' 'ocaml-ppx_driver' 'ocaml-ppx_expect' 'ocaml-ppx_inline_test' 'ocaml-ppx_jane' 'ocaml-sexplib' 'ocaml-typerep' 'ocaml-variantslib')
-makedepends=('ocaml-findlib')
+makedepends=('ocaml-findlib' 'ocaml-js-build-tools' 'opam')
source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz"
"libdir.patch")
options=('!strip')
-md5sums=('b62e14f62cfc2c44602affb19ab865f3'
+md5sums=('7b4a62f49660363aafd866b146522c44'
'7f0a951f1ac87385272ea7a6dd58762a')
prepare() {
@@ -30,6 +30,6 @@ build() {
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
+
make install LIBDIR="${pkgdir}$(ocamlc -where)"
}