summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2015-06-10 15:16:18 +0800
committerwenLiangcan2015-06-10 15:16:18 +0800
commit57388de24c1905a7ec37ec741de4cf8c8f6c044c (patch)
tree2396e1629dfe7e9adafd3c2aba56b1847165338e /PKGBUILD
downloadaur-57388de24c1905a7ec37ec741de4cf8c8f6c044c.tar.gz
ocaml-zed 1.3-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe2e2b39de30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: Taylor Venable <taylor@metasyntax.net>
+
+srcname='zed'
+pkgname="ocaml-${srcname}"
+pkgver='1.3'
+pkgrel=1
+pkgdesc='An abstract engine for text editing'
+arch=('i686' 'x86_64')
+url='https://github.com/diml/zed'
+license=('BSD')
+depends=('ocaml' 'ocaml-camomile' 'ocaml-react')
+makedepends=('ocaml-findlib')
+source=("https://github.com/diml/zed/archive/${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('59f1d4b08f4b156f21d2378d34fc5b7d')
+
+build() {
+ cd "$srcdir/${srcname}-${pkgver}"
+ ./configure
+
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make
+}
+
+
+package() {
+ mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
+ mkdir -p "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
+ cd "$srcdir/${srcname}-${pkgver}"
+ env DESTDIR="$pkgdir" \
+ OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
+ make install
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}