summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Cottle2024-02-13 14:18:43 +1100
committerAaron Cottle2024-02-13 14:18:43 +1100
commit1f1b83c0842fc4a8e551fc5bf53ff734e9297528 (patch)
tree0ed0406877cf98f0bc554e2e236056c159df6a55 /PKGBUILD
downloadaur-1f1b83c0842fc4a8e551fc5bf53ff734e9297528.tar.gz
init repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9169f2e209c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aaron Cottle <a@aaroncottle.au>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=ocean-sound-theme-git
+pkgdesc='Ocean Sound Theme for Plasma'
+pkgver=6.0.80_r98.g4b12a40
+_dirver=$(echo $pkgver | cut -d. -f1-3)
+pkgrel=1
+arch=(any)
+url='https://kde.org/plasma-desktop/'
+license=(LGPL-2.0-or-later)
+depends=()
+makedepends=(extra-cmake-modules-git
+ qt6-base)
+groups=(plasma)
+source=(git+https://invent.kde.org/plasma/ocean-sound-theme.git)
+sha256sums=('SKIP')
+
+conflicts=('ocean-sound-theme')
+provides=('ocean-sound-theme')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ocean-sound-theme
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}