summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFaerbit2015-12-29 00:10:36 +0100
committerFaerbit2015-12-29 00:10:36 +0100
commit74dc27471300563f3a4b73cfd77e8b16d810c26d (patch)
tree44278462715b3e3e32c93d0788412e363d19968e /PKGBUILD
parent53f308a17439380d3eab21e5e9448af8030df117 (diff)
downloadaur-oclint-git.tar.gz
Now using the system compiler. Also updated the dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45f92c25c62a..1dc9d32dd040 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ pkgdesc="Static code analysis tool for improving quality and reducing defects"
arch=('i686' 'x86_64')
url="http://oclint.org/"
license=('BSD')
-dependencies=('clang' 'clang-analyzer' 'llvm' 'llvm-libs')
-makedepends=('cmake' 'subversion' 'python2' 'libxml2' 'git' 'python')
+dependencies=('python2' 'zlib' 'ncurses')
+makedepends=('cmake' 'git' 'llvm' 'python' 'clang')
provides=('oclint')
conflicts=('oclint')
source=("git+http://github.com/oclint/oclint.git"
@@ -26,7 +26,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname/oclint-scripts"
- ./build -llvm-root=/usr -release
+ ./build -llvm-root=/usr -use-system-compiler -release
}
package() {