summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier2023-02-18 08:28:49 -0500
committerXavier2023-02-18 08:28:49 -0500
commite6deb7e896eaa1c124209552ea90d3445bcfff16 (patch)
tree2f3b648094bae100a4c480d1d2891615f7d58333 /PKGBUILD
parentffed816a835672f784cc71ee952a01c32edf5814 (diff)
downloadaur-e6deb7e896eaa1c124209552ea90d3445bcfff16.tar.gz
Bump to release 2 clarifying dependency semantics
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7bc3332a9560..f829633e5e33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase=ocp
pkgname=('ocp' 'ocp-sdl2')
pkgver=0.2.103
-pkgrel=1
+pkgrel=2
pkgdesc="Open Cubic Player"
arch=('i686' 'x86_64')
url="https://stian.cubic.org/project-ocp.php"
@@ -14,14 +14,15 @@ optdepends=('libvorbis: Vorbis codec support'
'libmad: MPEG codec support'
'flac: FLAC codec support')
-makedepends=('git'
- 'xa'
+makedepends=('alsa-libs'
+ 'cjson'
'desktop-file-utils'
- 'alsa-lib'
- 'sdl2'
- 'freetype2'
+ 'freetype2'
'flac'
- 'cjson'
+ 'git'
+ 'ncurses'
+ 'sdl2'
+ 'xa'
'libancient'
'libdiscid'
'libmad'
@@ -69,12 +70,14 @@ package_ocp-sdl2() {
'cjson'
'freetype2'
'hicolor-icon-theme'
+ 'ncurses'
'sdl2'
'shared-mime-info'
'libancient'
'libdiscid'
'libjpeg-turbo'
- 'libpng')
+ 'libpng'
+ 'ttf-unifont')
cd $_pkgbase
./configure --prefix=/usr --sysconfdir=/etc --with-builtin=core\
--without-update-desktop-database\
@@ -93,6 +96,7 @@ package_ocp() {
conflicts=('ocp-curses' 'ocp-sdl2')
depends=('alsa-lib'
'cjson'
+ 'ncurses'
'libancient'
'libdiscid')
cd $_pkgbase