summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-06-22 00:29:32 -0400
committerPatrick Northon2021-06-22 00:29:32 -0400
commit27cc54f9c80ac66c1ddf6c09fc724bbf04299c57 (patch)
tree20affe088588f991080886919dc7ade395d76449 /PKGBUILD
parentbacceafc3210d9efabb89e48d9d039e973458422 (diff)
downloadaur-27cc54f9c80ac66c1ddf6c09fc724bbf04299c57.tar.gz
Fix for python2-imaging.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 955f5b4a91f2..a84ed02c7bc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,10 @@ arch=('any')
url="https://github.com/ocropus/${_pkgname}"
license=('APACHE')
depends=('python2-imaging' 'python2-scipy' 'python2-matplotlib' 'python2-pytables'
- 'imagemagick' 'opencv' 'python2-beautifulsoup4')
+ 'imagemagick' 'opencv' 'python2-lxml')
makedepends=('git')
provides=("${_pkgname}")
+conflicts=("${_pkgname}")
source=("git+https://github.com/ocropus/${_pkgname}.git"
"https://github.com/zuphilip/ocropy-models/raw/master/en-default.pyrnn.gz")
sha256sums=('SKIP'
@@ -27,8 +28,11 @@ prepare() {
cd "$srcdir/${_pkgname}"
cp "$srcdir/en-default.pyrnn.gz" models
- sed -i 's|tostring|tobytes|' ocrolib/common.py
- sed -i 's|PIL\.Image\.fromstring|PIL\.Image\.frombytes|' ocrolib/common.py
+ #sed -i 's|numpy.fromstring|numpy.frombytes|' ocrolib/common.py
+ #sed -i 's|tostring|tobytes|' ocrolib/common.py
+ #sed -i 's|im.tobytes()|im.tostring()|' 'ocrolib/common.py'
+ #sed -i 's|PIL\.Image\.fromstring|PIL\.Image\.frombytes|' 'ocrolib/common.py'
+ sed -i 's|tobytes|tostring|' ocrolib/common.py
}
build() {