summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2020-01-23 21:08:00 -0500
committerDavid Birks2020-01-23 21:08:00 -0500
commit71dd9d42379bab84a5863e33164043cffc80a5b4 (patch)
treed6d99c6817770f258faea7b164b8be6c05d17403 /PKGBUILD
parent510e0b6b26b295733c6fbe9844306d29ac98021e (diff)
downloadaur-71dd9d42379bab84a5863e33164043cffc80a5b4.tar.gz
Update to 0.10.0
Change away from the makefile to a go build script due to: https://github.com/vmware-tanzu/octant/commit/4492f5beb2f002eba7eaaa97481809529dec57ae Change my email in the PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7a6a8c1dddd..1f4b58dc6a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: David Birks <david@tellus.space>
+# Maintainer: David Birks <david@birks.dev>
pkgname=octant
pkgdesc='A tool for developers to understand how applications run on a Kubernetes cluster'
-pkgver=0.9.1
+pkgver=0.10.0
pkgrel=1
arch=('x86_64')
license=('Apache')
@@ -10,13 +10,12 @@ url='https://github.com/vmware/octant'
depends=('kubectl')
makedepends=('go' 'npm')
source=("$pkgname-$pkgver.tar.gz::https://github.com/vmware/octant/archive/v$pkgver.tar.gz")
-sha256sums=('751c347f8efcaf05a36f8451979d3a0ede2b90a20fea4447b238c80f0522c136')
+sha256sums=('da7ab643408c0f4cb2af85d32a9335944bbd41d5569d8e7cebfda08df0e4e41a')
build() {
- export NG_CLI_ANALYTICS=ci
-
cd $pkgname-$pkgver
- make go-install ci
+ go run build.go go-install
+ go run build.go ci
}
package() {