summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-23 13:59:15 -0500
committerCarlos Aznarán Laos2022-01-23 13:59:15 -0500
commit24b0a20359b9c5bb238bedb80cad80e1e62282f0 (patch)
tree97c173b6e45fa686913f3d3ce5fb68b41650f9d5 /PKGBUILD
parentd746d9b33ccffb5a79120431f548ab1cdcbbd09d (diff)
downloadaur-24b0a20359b9c5bb238bedb80cad80e1e62282f0.tar.gz
Update upstream URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0dcc08cab2c..dd26c9a5a072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,52 +9,53 @@
#
_pack=bsltl
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.3.1
pkgrel=1
-pkgdesc="The BSLTL package is a free collection of OCTAVE/MATLAB routines for working with the biospeckle laser technique."
+pkgdesc="The BSLTL package is a free collection of OCTAVE/MATLAB routines for working with the biospeckle laser technique"
arch=(any)
-url="https://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
-depends=('octave>=3.8.0' 'octave-control>=2.2.3' 'octave-signal>=1.2.2')
+depends=('octave>=4.0.0')
makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("https://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-sha256sums=('4bb7ae78decc0d7f71bb553ba1270a3b69efaabed00a70c66ac5157fc8f01945')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('116483541f8968d8e56d13c3e2c7e60c2f065d87e17a5e0bfa6d08fdf13deb6631b0ecd35f1c145eecc7dd6cc36553fb75ef825926cdf02a23bac7eac1c927bc')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}