summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-19 19:33:29 -0500
committerCarlos Aznarán Laos2023-05-19 19:33:29 -0500
commitf22b9ca9025e2b5a8def33c39f1033f573dd3dc3 (patch)
treefb525908058a1b3e735a5f4687c9244388cbc37a /PKGBUILD
parent026e8f2a6c6500cef528a442c100ec639f402f2a (diff)
downloadaur-octave-communications.tar.gz
Bump version to 1.2.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 28 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c9bd7288c9a..076905f21313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
#
-# Maintainer: Jonathan Liu <net147@gmail.com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Jonathan Liu <net147@gmail.com>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -8,11 +9,11 @@
_pack=communications
pkgname=octave-$_pack
-pkgver=1.2.5
+pkgver=1.2.6
pkgrel=1
pkgdesc="Digital Communications, Error Correcting Codes (Channel Code), Source Code functions, Modulation and Galois Fields"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://gnu-octave.github.io/packages/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=4.4.0' 'octave-signal>=1.1.3')
@@ -20,39 +21,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('ffe748509875530bda482a1a7435b217')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("http://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('562b85370d377d6e940430bf0531cf812ac1907e55f2d0a7ca4380876befbe4fa2a44bfcf6484505c9f17c67e44993bf1e3ae29b881320a048259172273bb8ec')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
- pkg local_list octave_packages;
- pkg prefix $_prefix $_archprefix;
- pkg install -verbose -nodeps $_archive;
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}