summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwangjiezhe2016-12-19 20:48:00 +0800
committerwangjiezhe2016-12-19 20:48:00 +0800
commit97c2ea9ba49c75bbd96bb96e10a8fdba5ca7f1de (patch)
treeeecbfa625150c1b9550135e211f5e0cf55eca989 /PKGBUILD
parent292f9b0abfec5e209f3e844429e270078927e627 (diff)
downloadaur-97c2ea9ba49c75bbd96bb96e10a8fdba5ca7f1de.tar.gz
rebuild for octave 4.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53af760bc036..d92bb81bf4f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pack=data-smoothing
pkgname=octave-$_pack
pkgver=1.3.0
-pkgrel=2
+pkgrel=4
pkgdesc="Algorithms for smoothing noisy data"
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -26,6 +26,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('d8fc52ed097b5096f5e7ea16dc5ab343')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;