summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwangjiezhe2015-12-14 20:41:50 +0800
committerwangjiezhe2015-12-14 20:41:50 +0800
commit02aa52974ef71596c3185e16554835b3c09dc90f (patch)
tree87af169eb425f983924792cf98832dd68ab8f29a /PKGBUILD
parent1ed35630770b81ebe1edd273f190b7638ca10305 (diff)
downloadaur-02aa52974ef71596c3185e16554835b3c09dc90f.tar.gz
C++11 ABI rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89388c561d9b..bdd4e3caa0eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pack=mechanics
pkgname=octave-$_pack
pkgver=1.3.1
-pkgrel=2
+pkgrel=4
pkgdesc="Library with functions useful for numerical computation in classical mechanics and structural analysis."
arch=(any)
url="http://octave.sourceforge.net/$_pack/"
@@ -26,6 +26,10 @@ source=("http://downloads.sourceforge.net/octave/$_archive")
noextract=("$_archive")
md5sums=('24382a5047a944ac98c41a277c264e04')
+_octave_run() {
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+}
+
_install_dir() {
src=$1
dst=$2
@@ -38,7 +42,7 @@ build() {
_archprefix="$srcdir"/install_archprefix
mkdir -p "$_prefix" "$_archprefix"
cd "$srcdir"
- octave -q -f --eval "$(cat <<-EOF
+ _octave_run "$(cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;