summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 15:47:51 -0500
committerCarlos Aznarán Laos2022-01-24 15:47:51 -0500
commitfa66ecace7a93d8f2bebad2feaea41151f4abc21 (patch)
tree8840074fd6ae9f0954800518054e914304f50461 /PKGBUILD
parent24acb5b4e119d7b9d16ce2307ef7de50cb76f935 (diff)
downloadaur-fa66ecace7a93d8f2bebad2feaea41151f4abc21.tar.gz
Update upstream URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 30 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40a7d00aff82..0b2d88a599e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,12 +9,12 @@
#
_pack=mechanics
-pkgname=octave-$_pack
+pkgname=octave-${_pack}
pkgver=1.3.1
pkgrel=5
-pkgdesc="Library with functions useful for numerical computation in classical mechanics and structural analysis."
+pkgdesc="Library with functions useful for numerical computation in classical mechanics and structural analysis"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=3.4.0' 'octave-linear-algebra>=2.0.0' 'octave-general>=1.2.2' 'octave-geometry>=1.2.1')
@@ -20,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('24382a5047a944ac98c41a277c264e04')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('e70d0e6e0918c052c7339e8979cebd2fcda63333c1ab2a05e45bf174b60dd7601e02e255dc97dbc359d59114b52f2654f2b7be6046a9f6885ac5f0a29f740e87')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
- pkg local_list octave_packages;
- pkg prefix $_prefix $_archprefix;
- pkg install -verbose -nodeps $_archive;
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
+ pkg local_list octave_packages;
+ pkg prefix $_prefix $_archprefix;
+ pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}