summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-24 18:16:46 -0500
committerCarlos Aznarán Laos2022-01-24 18:16:46 -0500
commitffb5d17fe651300dfeb43578ec032ca9ec3b305a (patch)
tree844a1beb746cc562e8414fc1c8da874a7757317f /PKGBUILD
parent6af45bfd1c0a77deffa179af3f646280a8d39717 (diff)
downloadaur-ffb5d17fe651300dfeb43578ec032ca9ec3b305a.tar.gz
Version bump to 1.2.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22ddaade7124..df84d7c7b0a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
#
-# Maintainer: Clemens Buchacher <drizzd@aon.at>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: wangjiezhe <wangjiezhe@gmail.com>
+# Contributor: Clemens Buchacher <drizzd@aon.at>
#
# You can use the newpkg script from
# https://github.com/drizzd/octave-forge-archlinux to automatically generate
@@ -7,12 +9,12 @@
#
_pack=queueing
-pkgname=octave-$_pack
-pkgver=1.2.6
+pkgname=octave-${_pack}
+pkgver=1.2.7
pkgrel=1
-pkgdesc="The queueing package provides functions for queueing networks and Markov chains analysis. This package can be used to compute steady-state performance measures for open, closed and mixed networks with single or multiple job classes. Mean Value Analy [...]"
+pkgdesc="The queueing package provides functions for queueing networks and Markov chains analysis"
arch=(any)
-url="http://octave.sourceforge.net/$_pack/"
+url="https://octave.sourceforge.io/${_pack}"
license=('GPL3')
groups=('octave-forge')
depends=('octave>=4.0.0')
@@ -20,39 +22,40 @@ makedepends=()
optdepends=()
backup=()
options=()
-install=$pkgname.install
-_archive=$_pack-$pkgver.tar.gz
-source=("http://downloads.sourceforge.net/octave/$_archive")
-noextract=("$_archive")
-md5sums=('d13c222283c753b73b29a0b5825591e5')
+install=${pkgname}.install
+_archive=${_pack}-${pkgver}.tar.gz
+source=("https://downloads.sourceforge.net/octave/${_archive}")
+noextract=("${_archive}")
+sha512sums=('b9788a9a6e376836ef6e82d28f3949aaded409520779f1e6caa3805e5672c2b944f6fb1c4c26f5276549d35714524406cb857108a818fb72cdb0f3d855cc17da')
_octave_run() {
- octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
+ octave --no-history --no-init-file --no-window-system -q -f --eval "$*"
}
_install_dir() {
- src=$1
- dst=$2
- mkdir -p "$(dirname "$dst")"
- cp -rT "$src" "$dst"
+ src=$1
+ dst=$2
+ mkdir -p "$(dirname "$dst")"
+ cp -rT "$src" "$dst"
}
build() {
- _prefix="$srcdir"/install_prefix
- _archprefix="$srcdir"/install_archprefix
- mkdir -p "$_prefix" "$_archprefix"
- cd "$srcdir"
- _octave_run "$(cat <<-EOF
+ _prefix="$srcdir"/install_prefix
+ _archprefix="$srcdir"/install_archprefix
+ mkdir -p "$_prefix" "$_archprefix"
+ cd "$srcdir"
+ _octave_run "$(
+ cat <<-EOF
pkg local_list octave_packages;
pkg prefix $_prefix $_archprefix;
pkg install -verbose -nodeps $_archive;
EOF
- )"
+ )"
}
package() {
- prefix=$pkgdir/usr/share/octave/packages
- archprefix=$pkgdir/usr/lib/octave/packages
- _install_dir "$srcdir"/install_prefix "$prefix"
- _install_dir "$srcdir"/install_archprefix "$archprefix"
+ prefix=$pkgdir/usr/share/octave/packages
+ archprefix=$pkgdir/usr/lib/octave/packages
+ _install_dir "$srcdir"/install_prefix "$prefix"
+ _install_dir "$srcdir"/install_archprefix "$archprefix"
}