summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAzael Reyes2020-04-15 09:30:58 -0700
committerAzael Reyes2020-04-15 09:30:58 -0700
commitf9d6db59058d10ea236b8b5ed5dca5acce44cb8a (patch)
tree304840508ae610ae6b8dc7d9fb91dfa7569b1612 /PKGBUILD
downloadaur-f9d6db59058d10ea236b8b5ed5dca5acce44cb8a.tar.gz
Adding package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8511b0c67f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Azael Reyes <azael.devel@gmail.com>
+
+
+pkgname=octetos-db-maria
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="C++ library for Database Acces."
+arch=('x86_64')
+license=('GPL')
+url="https://github.com/azaeldevel/octetos-db"
+depends=('octetos-core' 'mariadb-connector-c')
+#backup=('etc/nanorc')
+md5sums=('421c868a351e0c350827905ab561b8e3')
+source=(https://github.com/azaeldevel/octetos-db/archive/1.2.2-alpha.6.tar.gz)
+
+build() {
+ cd octetos-db-1.2.2-alpha.6
+ autoreconf -fi
+ ./configure --prefix=/usr --sysconfdir=/etc --with-mariadb
+ make
+}
+
+package() {
+ cd octetos-db-1.2.2-alpha.6
+ make DESTDIR="${pkgdir}" install
+}