summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2019-11-23 18:36:49 -0500
committerAndrew Sun2019-11-23 18:36:49 -0500
commit026ccc350dd9da5ea696100e7762c340afe73a4b (patch)
treea229c56a945d000e6cb986dba030e62987a8c74b /PKGBUILD
parente5dac62b641296c8bd3fca308f8f2f7c3a4eb55d (diff)
downloadaur-026ccc350dd9da5ea696100e7762c340afe73a4b.tar.gz
octomap: update to 1.9.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d2fcc42837c..558a86672155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
# Contributor: Benjamin Chrétien <chretien dot b+arch at gmail dot com>
-# Contributor: Soo-Hyun Yoo <yoos117@gmail.com>
+# Contributor: Soo-Hyun Yoo <yoos117 at gmail dot com>
pkgname=octomap
-pkgver=1.9.0
-pkgrel=2
-pkgdesc="A probabilistic, flexible, and compact 3D mapping library for robotic systems."
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="Efficient probabilistic 3D mapping framework based on octrees"
arch=('i686' 'x86_64')
url="http://octomap.github.com/"
license=('BSD')
@@ -15,21 +15,21 @@ provides=('octomap')
conflicts=('octomap-git')
options=('staticlibs')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/OctoMap/octomap/archive/v${pkgver}.tar.gz")
-sha256sums=('5f81c9a8cbc9526b2e725251cd3a829e5222a28201b394314002146d8b9214dd')
+sha256sums=('9abce615d9f3f97a15ba129a10e3a01f9bef9aad178f2ef398f9a925f793c7b9')
build() {
cd "$srcdir/octomap-$pkgver/octomap"
mkdir build && cd build
cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "$srcdir/octomap-$pkgver/octomap"
cd build
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
# vim: ts=2 sw=2 et: