summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatMoul2023-01-14 21:12:53 +0100
committerMatMoul2023-01-14 21:12:53 +0100
commitce71292fe331805e66505bf5f2e0a4162005607b (patch)
treef59619ce2572355a6c5472b6e7b6784956539b9c /PKGBUILD
parent8ed03c74bc9eceda8be47892297264e7a3d38a35 (diff)
downloadaur-ce71292fe331805e66505bf5f2e0a4162005607b.tar.gz
Version 0.14.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 29 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 155f00d43bf9..d4209362a266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: MatMoul <matmoul@gmail.com>
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-_pkggit=octopi
-_gitcommit=0a47127c711c20f9f8f4c42298a25992dbbf98b9
-_gitsha256='41cf58d9fd12143e34b75798cc65ad467aed69257c8e04a7b9cbee77ae01d133'
+_githubuser=aarnt
+_githubrepo=octopi
+_pkgtagname=v0.14.0
-pkgbase=octopi
-pkgname='octopi'
+pkgname=octopi
pkgver=0.14.0
pkgrel=2
-pkgdesc="This is Octopi, a powerful Pacman frontend using Qt libs"
-arch=('i686' 'x86_64')
+pkgdesc='This is Octopi, a powerful Pacman frontend using Qt libs'
+arch=('any')
url="https://tintaescura.com/projects/octopi/"
license=('GPL2')
depends=('alpm_octopi_utils' 'pkgfile' 'qtermwidget' 'sudo')
@@ -23,41 +22,34 @@ optdepends=('octopi-notifier-qt5: Notifier for Octopi using Qt5 libs'
'yay: for AUR support'
'pacmanlogviewer: to view pacman log files')
provides=('octopi' 'octopi-repoeditor' 'octopi-cachecleaner')
-conflicts=('octopi')
-source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz")
-sha256sums=(${_gitsha256})
-
-_subdirs=(helper repoeditor cachecleaner sudo)
+source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
+sha256sums=('9b548661807fe8eecc20726a4aefa25658c4ce1bf1bc8f51b54829809d76f12d')
prepare() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
- cp resources/images/octopi_green.png resources/images/octopi.png
+ cd "${_githubrepo}-${pkgver}"
+ cp resources/images/octopi_green.png resources/images/octopi.png
}
build() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- echo "Starting build..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro
- make
-
- for _subdir in ${_subdirs[@]}; do
- pushd $_subdir
- echo "Building octopi-$_subdir..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" "octopi-$_subdir.pro"
- make
- popd
- done
+ cd "${_githubrepo}-${pkgver}"
+ echo "Starting build..."
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro
+ make
+ for _subdir in ${_subdirs[@]}; do
+ pushd $_subdir
+ echo "Building octopi-$_subdir..."
+ qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" "octopi-$_subdir.pro"
+ make
+ popd
+ done
}
package() {
- cd "${srcdir}/${_pkggit}-${_gitcommit}"
-
- make INSTALL_ROOT="${pkgdir}" install
-
- for _subdir in ${_subdirs[@]}; do
- pushd $_subdir
- make INSTALL_ROOT="${pkgdir}" install
- popd
- done
+ cd "${_githubrepo}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+ for _subdir in ${_subdirs[@]}; do
+ pushd $_subdir
+ make INSTALL_ROOT="${pkgdir}" install
+ popd
+ done
}