summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJake2020-12-15 12:30:23 +0100
committerJake2020-12-15 12:30:23 +0100
commitd3b4769803d8121dfe7160aba3e9173efb28fac6 (patch)
tree7116adfe835c5a7b96643717b0f8e77e91bd4b1b /PKGBUILD
parent8d96e9fd56313b7f9dd16caf708cae9450c21cc0 (diff)
downloadaur-d3b4769803d8121dfe7160aba3e9173efb28fac6.tar.gz
Manual netifaces install for arm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6303d292edee..5b453be21cc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,12 @@ package() {
cd "${srcdir}/OctoPrint-${pkgver}"
python3 -m venv "${pkgdir}/opt/$pkgname"
+
+ if [ ! "$CARCH" == "x86_64" ] && [ ! "$CARCH" == "i686" ]; then
+ "${pkgdir}/opt/$pkgname/bin/pip3" install wheel
+ "${pkgdir}/opt/$pkgname/bin/pip3" install netifaces
+ fi
+
"${pkgdir}/opt/$pkgname/bin/python3" setup.py install --optimize=1
sed -i "s|${pkgdir}/opt/$pkgname|/opt/$pkgname|g" "${pkgdir}/opt/$pkgname/bin/"* # relocate without breaking plugin system