summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJameson Pugh2021-06-16 14:21:06 -0400
committerJameson Pugh2021-06-16 14:21:06 -0400
commit221a1940a0bfbcfe010de621ad9c4085e52d5f4f (patch)
treeb4d22ef207596c0a9fb99a094d5beae6db629d85 /PKGBUILD
parent787f70f5361dcfebea5430632f86209d1e1b6860 (diff)
downloadaur-oddjob.tar.gz
0.34.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 949a26adb676..739e0403409d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
build_selinux=false
pkgname=oddjob
-pkgver=0.34
+pkgver=0.34.7
pkgrel=1
pkgdesc="A D-Bus service which runs odd jobs on behalf of client applications"
arch=(i686 x86_64)
url="https://releases.pagure.org/oddjob/"
license=(BSD)
-depends=(cyrus-sasl dbus krb5 libxml2 openldap pam python2 systemd)
+depends=(cyrus-sasl dbus krb5 libxml2 openldap pam python systemd)
+makedepends=(libselinux)
if [[ "${build_selinux}" == "true" ]]; then
depends+=(selinux-usr-libselinux)
@@ -18,25 +19,21 @@ fi
backup=(etc/oddjobd.conf.d/oddjobd-introspection.conf
etc/oddjobd.conf.d/oddjobd-mkhomedir.conf
- etc/oddjobd.conf)
+ etc/oddjobd.conf
+ 0001_Remove_SELinux_support.patch)
options=(!libtool)
install=${pkgname}.install
-source=("https://releases.pagure.org/oddjob/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('df62a58f86087542876d614c084ec260861a7666bc267747ea45b063d000995f19d275cbc9c09a91dd7adf964f2297bf01a2a0f85339f157817c49bdbafaafab')
-
-if [[ "${build_selinux}" == "false" ]]; then
- source+=(0001_Remove_SELinux_support.patch)
- sha512sums+=('2a9a1ffaaf875c66844e3795f65a2efe2f054860734214ff41eaefdf9355137dbf81a5edf54ee735f4c8c70ee430ee96bc801adf365afc0e5eda5290632acdda')
-fi
+source=("https://pagure.io/oddjob/archive/${pkgname}-${pkgver}/${pkgname}-${pkgname}-${pkgver}.tar.gz")
+sha512sums=('f7a29058bee063d88ae69e1256dd8a8db152fb6a79790780ea661fd4cd4f82385470dc9015419aa47a7bccd4f5673e68c07471cbc3c00586e5a3d1b175a09b99')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgname}-${pkgver}"
SELINUX_OPTIONS=""
if [[ "${build_selinux}" == "true" ]]; then
SELINUX_OPTIONS="--with-selinux-acls --with-selinux-labels"
else
- patch -p1 -i ../0001_Remove_SELinux_support.patch
+ #patch -p1 -i ../0001_Remove_SELinux_support.patch
aclocal --force --install
autoreconf -vfi
fi
@@ -60,6 +57,6 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
}