summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Kaster2024-04-16 21:27:01 +0200
committerChristopher Kaster2024-04-16 21:27:01 +0200
commit95eb02cd24a1f747042f53bbda158909ef11d4bb (patch)
tree89824da6d55b9e6bc70bd5cb81277ae51f55fdb3 /PKGBUILD
parent5a9720782e0ac0338fb560c726307c8cec5ec6f1 (diff)
downloadaur-odin-bin.tar.gz
fix setup not working properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47624b410392..3218fe1cca71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,14 @@ pkgname=odin-bin
pkgver_fixed=${pkgver//_/-}
pkgrel=1
pkgdesc="A fast, concise, readable, pragmatic and open sourced programming language."
-arch=('x86_64')
+arch=("x86_64")
url="https://odin-lang.org/"
-license=('BSD-2-Clause')
-depends=('clang' 'llvm-libs' 'libedit')
-provides=('odin')
-conflicts=('odin' 'odin-git')
-options=('staticlibs')
+license=("BSD-2-Clause")
+depends=("clang" "llvm-libs" "libedit")
+makedepends=("unzip" "patchelf")
+provides=("odin")
+conflicts=("odin" "odin-git")
+options=("staticlibs")
source=(
"https://github.com/odin-lang/Odin/releases/download/dev-$pkgver_fixed/odin-ubuntu-amd64-dev-$pkgver_fixed.zip"
@@ -26,6 +27,7 @@ sha256sums=(
build() {
unzip "${srcdir}/dist.zip"
cd "${srcdir}/dist"
+ patchelf --replace-needed libedit.so.2 libedit.so.0 libLLVM-17.so.1
chmod +x odin
}