summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2018-04-06 18:58:57 +0200
committerSebastiaan Lokhorst2018-04-06 18:58:57 +0200
commitea9293090653e7322609a8e19240d387c42c5b92 (patch)
tree410933aee0a9da21b4977bcd32f2788aec18b916 /PKGBUILD
parent71317a361b6d626abbb0bbb7574420c7745bef55 (diff)
downloadaur-ea9293090653e7322609a8e19240d387c42c5b92.tar.gz
Cleanup dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD87
1 files changed, 44 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02a2aeea3b32..3a094f7c1781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,52 +8,53 @@ pkgrel=1
pkgdesc="Web-based Open Source Business Apps"
url=https://www.odoo.com/
arch=('any')
-license=(GPL3)
+license=('GPL3')
conflicts=('openerp')
replaces=('openerp')
+makedepends=('python-setuptools')
depends=(
- nodejs-less-plugin-clean-css
- postgresql-libs
- wkhtmltopdf
- python
- python-babel
- python-decorator
- python-docutils
- python-ebaysdk
- python-feedparser
- python-gevent
- python-greenlet
- python-html2text
- python-jinja
- python-lxml
- python-mako
- python-markupsafe
- python-mock
- python-num2words
- python-ofxparse
- python-passlib
- python-pillow
- python-psutil
- python-psycopg2
- python-pydot
- python-ldap
- python-pyparsing
- python-pypdf2
- python-pyserial
- python-dateutil
- python-pytz
- python-pyusb
- python-yaml
- python-qrcode
- python-reportlab
- python-requests
- python-suds
- python-vatnumber
- python-vobject
- python-werkzeug
- python-xlsxwriter
- python-xlwt
- python-xlrd
+ 'nodejs-less'
+ 'postgresql-libs'
+ 'wkhtmltopdf'
+ 'python'
+ 'python-babel'
+ 'python-decorator'
+ 'python-docutils'
+ 'python-ebaysdk'
+ 'python-feedparser'
+ 'python-gevent'
+ 'python-greenlet'
+ 'python-html2text'
+ 'python-jinja'
+ 'python-lxml'
+ 'python-mako'
+ 'python-markupsafe'
+ 'python-mock'
+ 'python-num2words'
+ 'python-ofxparse'
+ 'python-passlib'
+ 'python-pillow'
+ 'python-psutil'
+ 'python-psycopg2'
+ 'python-pydot'
+ 'python-ldap'
+ 'python-pyparsing'
+ 'python-pypdf2'
+ 'python-pyserial'
+ 'python-dateutil'
+ 'python-pytz'
+ 'python-pyusb'
+ 'python-yaml'
+ 'python-qrcode'
+ 'python-reportlab'
+ 'python-requests'
+ 'python-suds'
+ 'python-vatnumber'
+ 'python-vobject'
+ 'python-werkzeug'
+ 'python-xlsxwriter'
+ 'python-xlwt'
+ 'python-xlrd'
)
source=("https://nightly.odoo.com/${pkgver}/nightly/src/${pkgname}_${pkgver}.${_pkgsubver}.tar.gz"