summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlothar-mar2015-07-19 23:42:07 +0100
committerlothar-mar2015-07-19 23:42:07 +0100
commit55beb990143c2e951afde394b75b445e4213e7f1 (patch)
tree8c12c2971840a00167498378f4d42d684081edcf /PKGBUILD
parent995ad6d5221fc09d0265a71eaae00aa140f51680 (diff)
downloadaur-55beb990143c2e951afde394b75b445e4213e7f1.tar.gz
updated version function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21024f73512b..fe82127a83c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,18 @@ depends=('python2>=2.7.6'
#optdepends=('')
provides=($_pkgname)
conflicts=($_pkgname)
-source=($_pkgname::git://github.com/jseutter/ofxparse.git)
+source=('ofxparse::git+https://github.com/jseutter/ofxparse.git#branch=master')
md5sums=('SKIP')
-
+
+
pkgver() {
- cd $_pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
+
build() {
cd $_pkgname