summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Blankertz2019-03-11 21:57:22 +0100
committerMatthias Blankertz2019-03-11 21:57:22 +0100
commit5ec83519232bd6d331a490eb84d4b870f6de1f4e (patch)
tree299fd1b729a33ff2ef9aa3a068d6438cfc7d09c0 /PKGBUILD
parent39ce77aeb8a422737245d65b885e711c6d7c144d (diff)
downloadaur-5ec83519232bd6d331a490eb84d4b870f6de1f4e.tar.gz
Disable GCC 8 errors causing compile failure
Should be reenabled when upstream updates w/ GCC 8 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 093042001cde..2a5eaa7ff54a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('ogdf-snapshot' 'ogdf-snapshot-docs')
pkgver=2018_03_28
-pkgrel=1
+pkgrel=2
pkgdesc="OGDF is a self-contained C++ class library for the automatic layout of diagrams. OGDF offers sophisticated algorithms and data structures to use within your own applications or scientific projects."
arch=('i686' 'x86_64')
url="http://amber-v7.cs.tu-dortmund.de/doku.php/start"
@@ -15,7 +15,7 @@ sha256sums=("347c3fa8dcdbb094f9c43008cbc2934bc5a64a532af4d3fe360a5fa54488440f")
build() {
cd "$srcdir/OGDF-snapshot"
- cmake -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${CPPFLAGS}" \
+ cmake -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${CPPFLAGS} -Wno-class-memaccess -Wno-error=restrict" \
-DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
-DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=true \
-DCMAKE_INSTALL_PREFIX="$pkgdir" .