summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2017-06-04 23:49:26 -0400
committerChris Severance2017-06-04 23:49:26 -0400
commit827f88247c3f4d1a16ac781c21b9da1acff70109 (patch)
tree1ee952c51e436739a9e78fa163e2b7b629640e2d /PKGBUILD
parentac2505c9ce821194ce817b09f1b57f7121f34b2d (diff)
downloadaur-827f88247c3f4d1a16ac781c21b9da1acff70109.tar.gz
Update description
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ce9762ef9b9..68af3e247c60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,36 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Category: system
-# Recommended build & install command: makepkg -scCfi
-
set -u
pkgname='oki-b411-b431'
_pkgnick='MB400PCL'
pkgver='5.0.0'
-pkgrel=1
-pkgdesc='cups driver for the Okidata B411 and B431'
-url='http://www.okidata.com/'
+pkgrel='1'
+pkgdesc='CUPS printer driver for the Okidata B411 and B431'
arch=('i686' 'x86_64')
+url='http://www.okidata.com/'
license=('GPL')
depends=('cups')
# install="${pkgname}.install"
-# An install is not necessary. Printers appear and disappear from cups
+# An Install is not necessary. Printers appear and disappear from cups
# without a systemctl reload org.cups.cupsd.service or killall -HUP cupsd
source=('ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/MB400PCLv5.tar')
sha256sums=('3ab2df56a62e03d0c0f8dcbb09ea7cde757eac3eb9ab1772f5f3c421cbb6c73f')
prepare() {
set -u
- #cd "${pkgname}-${pkgver}"
cd "${_pkgnick}"
# There's 101 ways to hack up this installer. I choose to
# fix it the way it should be for most package makers.
- chmod 755 install.sh
- sed -i -e 's:^\(_CUPS[A-Z]*="\):# \1:g' \
- -e 's:PATH="\(/usr/\):PATH="${DESTDIR}\1:g' \
- -e 's:^\(for i in \${_CUPS}\):if [ "${DESTDIR}" != "" ]; then\n\texit 0\nfi\n\n\1:g' \
- -e 's:\(\${CHOWN}\):# \1:g' \
- -e 's:\(\${CHGRP}\):true # \1:g' \
- -e 's:^\(PATH=/\):# \1:g' \
- -e 's:^\(export PATH\):# \1:g' \
- -e 's:^if \[ \(`${ID} -u`\):if \[ "${DESTDIR}" = "" -a \1:g' 'install.sh'
+ chmod 755 'install.sh'
+ sed -e 's:^\(_CUPS[A-Z]*="\):# \1:g' \
+ -e 's:PATH="\(/usr/\):PATH="${DESTDIR}\1:g' \
+ -e 's:^\(for i in \${_CUPS}\):if [ "${DESTDIR}" != "" ]; then\n\texit 0\nfi\n\n\1:g' \
+ -e 's:\(\${CHOWN}\):# \1:g' \
+ -e 's:\(\${CHGRP}\):true # \1:g' \
+ -e 's:^\(PATH=/\):# \1:g' \
+ -e 's:^\(export PATH\):# \1:g' \
+ -e 's:^if \[ \(`${ID} -u`\):if \[ "${DESTDIR}" = "" -a \1:g' -i 'install.sh'
set +u
}
@@ -42,7 +39,8 @@ package() {
cd "${_pkgnick}"
install -d "${pkgdir}/usr/share/cups/model"
install -d "${pkgdir}/usr/lib/cups/filter"
- sh -c "export DESTDIR='${pkgdir}'; ./install.sh"
+ DESTDIR="${pkgdir}" \
+ sh -u -e 'install.sh'
set +u
}
set +u