summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Shi2020-04-23 22:13:39 +0800
committerSimon Shi2020-04-23 22:13:39 +0800
commit332293aadb98b0730a1038aa841a93f8edc95a94 (patch)
tree4cac51e63d837261d037924c84fb3af9d2af35a1 /PKGBUILD
downloadaur-332293aadb98b0730a1038aa841a93f8edc95a94.tar.gz
PKGBUILD: init okteto-bin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b7d083487a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: simonsmh <simonsmh@gmail.com>
+pkgname=okteto-bin
+pkgver=1.8.4
+pkgrel=1
+pkgdesc="Build better applications by developing and testing your code directly in Kubernetes."
+arch=(x86_64 aarch64)
+url="https://github.com/okteto/okteto"
+license=(Apache)
+conflicts=(okteto)
+provides=(okteto=$pkgver)
+optdepends=(kubectl)
+source_x86_64=("okteto::https://github.com/okteto/okteto/releases/download/$pkgver/okteto-Linux-x86_64")
+source_aarch64=("okteto::https://github.com/okteto/okteto/releases/download/$pkgver/okteto-Linux-arm64")
+sha256sums_x86_64=('e59845ecbc12eed96cff7f2750819fcb1d4d29ec3cd67ed2270af48cff376e95')
+sha256sums_aarch64=('a9f6ec6f02d0f9926c399987f00072a71aaa0226a953c5cbc1eb336d3bedcc53')
+
+package() {
+ install -Dm755 "$srcdir/okteto" "$pkgdir"/usr/bin/okteto
+}