summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormikacousin2020-08-22 11:31:28 +0200
committermikacousin2020-08-22 11:31:28 +0200
commite0c56b41bb29ec9b912873a4723f0563925237eb (patch)
tree2931c7a2497cdf688051e8a006400d6f0b1e6f47 /PKGBUILD
downloadaur-e0c56b41bb29ec9b912873a4723f0563925237eb.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..708d2a6ff215
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mika Cousin <mika dot cousin at gmail dot com>
+
+pkgname=olc-git
+pkgver=0.2.alpha
+pkgrel=1
+pkgdesc='Open Lighting Console'
+arch=(any)
+url=https://github.com/mikacousin/olc
+license=(GPL3)
+depends=(
+ ola-git
+ gtk3
+ python-cairo
+ python-gobject
+ python-psutil
+ portmidi
+ python-mido
+ python-pyliblo
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+)
+provides=('olc')
+source=('git+https://github.com/mikacousin/olc')
+
+pkgver() {
+ cd "$srcdir/olc"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson olc build --libexec='lib/olc'
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+md5sums=('SKIP')