summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2019-04-02 01:48:34 -0300
committerTércio Martins2019-04-02 01:48:34 -0300
commita5f424af50ed671761eea3855648df1f6a62f0a8 (patch)
tree2c94f92848f7e1f3d4f017bff33c47018a81eb88 /PKGBUILD
downloadaur-a5f424af50ed671761eea3855648df1f6a62f0a8.tar.gz
Adding PKGBUILD to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..009a3ac23129
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=olive-community-effects-git
+_pkgname=Olive-Editor-Community-Effects
+pkgver=r34.fe15bf9
+_commit=fe15bf9
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A collection of effects for Olive made by the community"
+url="https://github.com/cgvirus/Olive-Editor-Community-Effects"
+license=('unknown')
+depends=('olive-git')
+makedepends=('git')
+conflicts=('olive')
+source=("git+https://github.com/cgvirus/$_pkgname#commit=$_commit")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/olive-editor/effects/$_pkgname"
+ cp -r --preserve=mode,timestamps \
+ $srcdir/$_pkgname/* \
+ $pkgdir/usr/share/olive-editor/effects/$_pkgname/
+}