summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2023-07-08 19:19:50 -0300
committerTércio Martins2023-07-08 19:19:50 -0300
commit14a91267dcf1f091f319a49f31c843913de0caee (patch)
tree1c9c5d28f9f6b86045a9b210b77227d7b97ef358 /PKGBUILD
parente8b159420ddbd80a5030ac31868f12511f4e5177 (diff)
downloadaur-14a91267dcf1f091f319a49f31c843913de0caee.tar.gz
Revert "Remove dependency "libolivecore""
This reverts commit e8b159420ddbd80a5030ac31868f12511f4e5177.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2af4ec206f93..64f56f4d25dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,10 @@ makedepends=('cmake' 'git' 'ninja' 'qt5-svg' 'qt5-tools')
provides=('olive')
conflicts=('olive')
source=('git+https://github.com/olive-editor/olive.git'
- 'git+https://github.com/olive-editor/KDDockWidgets.git')
+ 'git+https://github.com/olive-editor/KDDockWidgets.git'
+ 'git+https://github.com/olive-editor/core.git')
sha512sums=('SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -32,6 +34,7 @@ pkgver() {
prepare(){
cd $_pkgname
git submodule init
+ git config submodule.ext/core.url "$srcdir"/core
git config submodule.ext/KDDockWidgets.url "$srcdir"/KDDockWidgets
git -c protocol.file.allow=always submodule update
}