summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2021-11-01 20:15:07 -0300
committerTércio Martins2021-11-01 20:15:07 -0300
commit41de4e14683a674304f753e0bc0debf29fe4df33 (patch)
tree92c0bad3409a43e6ed9bb7483fb9905814d2917a /PKGBUILD
parent2e7567fbaad606b8c5779f6e77007b2ea95bbecf (diff)
downloadaur-41de4e14683a674304f753e0bc0debf29fe4df33.tar.gz
Switching the OpenTimelineIO library to the stable version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8398e420783..dfd5a27f9675 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=olive-git
_pkgname=${pkgname%-*}
-pkgver=continuous.r1315.g251b4d537
+pkgver=continuous.r1409.gcf1bd65b1
pkgrel=1
arch=('pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'openimageio' 'opentimelineio-git' 'portaudio' 'qt5-base')
+depends=('ffmpeg' 'openimageio' 'opentimelineio' 'portaudio' 'qt5-base')
makedepends=('cmake' 'git' 'ninja' 'qt5-svg' 'qt5-tools')
# Temporarily, the "olive-git" package is incompatible
@@ -28,10 +28,17 @@ pkgver() {
}
prepare() {
+ cd $_pkgname
+
+ # Fixes for OpenTimelineIO integration
+ sed -i "s/CXX_STANDARD 14/CXX_STANDARD 17/" CMakeLists.txt
+ sed -i "s/(es/(es.outcome/g" \
+ app/task/project/loadotio/loadotio.cpp
+ sed -i "s/(es/(es.outcome/g" \
+ app/task/project/saveotio/saveotio.cpp
+
# Currently the build crashes in the "ffmpegdecoder.cpp" file (-Werror=stringop-overflow).
# The build completes normally when this warning is disabled.
-
- cd $_pkgname
sed -i "/Wshadow/a \ -Wno-stringop-overflow" CMakeLists.txt
}
@@ -40,7 +47,8 @@ build() {
cmake -GNinja \
-Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOTIO_DEPS_INCLUDE_DIR=/usr/include/opentimelineio
ninja -C build/
}