summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2021-12-23 00:55:07 -0300
committerTércio Martins2021-12-23 00:55:07 -0300
commit8bcc2dcff53cfc3976afd4b02254432c0f894a0e (patch)
tree084dfa119dc8297dcb24de0570ea310f4d9b3d21 /PKGBUILD
parent41de4e14683a674304f753e0bc0debf29fe4df33 (diff)
downloadaur-8bcc2dcff53cfc3976afd4b02254432c0f894a0e.tar.gz
Adjustments to build with the current version of the OpenTimelineIO library
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfd5a27f9675..e9a3d61e81f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=olive-git
_pkgname=${pkgname%-*}
-pkgver=continuous.r1409.gcf1bd65b1
+pkgver=continuous.r1444.ge902507e4
pkgrel=1
arch=('pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
@@ -30,12 +30,9 @@ pkgver() {
prepare() {
cd $_pkgname
- # Fixes for OpenTimelineIO integration
+ # The OpenTimelineIO library requires some features of C++17 standard.
+ # Olive uses C++14 by default, preventing the compilation of modules that use OpenTimelineIO.
sed -i "s/CXX_STANDARD 14/CXX_STANDARD 17/" CMakeLists.txt
- sed -i "s/(es/(es.outcome/g" \
- app/task/project/loadotio/loadotio.cpp
- sed -i "s/(es/(es.outcome/g" \
- app/task/project/saveotio/saveotio.cpp
# Currently the build crashes in the "ffmpegdecoder.cpp" file (-Werror=stringop-overflow).
# The build completes normally when this warning is disabled.