summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2019-05-06 00:50:46 -0300
committerTércio Martins2019-05-06 00:50:46 -0300
commit8dcc1baf23e2bc724dc8fa98c149762a12481c43 (patch)
treee9be3936b3719e2aaaa005f7be61c1cef0418d54 /PKGBUILD
parentf315a427f914f0ccd1a0efe2753538fa202c7093 (diff)
downloadaur-8dcc1baf23e2bc724dc8fa98c149762a12481c43.tar.gz
Update to commit b819a30c \(inclusion of the new pipeline\)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97c6030292a2..0a09c3168a70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,30 @@
pkgname=olive-git
_pkgname=olive
-pkgver=continuous.r0.gf81df006
-_commit=f81df006
+pkgver=continuous.r0.gb819a30c
+_commit=b819a30c
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
+depends=('ffmpeg' 'opencolorio' 'qt5-multimedia' 'qt5-svg')
makedepends=('cmake' 'git' 'qt5-tools')
-optdepends=('frei0r-plugins' 'olive-community-effects-git')
+
+# Temporarily, the "olive-git" package is incompatible
+# with the dependency "olive-community-effects-git".
+# More information on the link:
+# https://github.com/cgvirus/Olive-Editor-Community-Effects/blob/65b96e093c128f2bb9336e6b7ed93f801e73435d/README.md
+# optdepends=('olive-community-effects-git')
+
provides=('olive')
conflicts=('olive')
-source=("git+https://github.com/olive-editor/olive#commit=$_commit")
-sha512sums=('SKIP')
+source=("git+https://github.com/olive-editor/olive#commit=$_commit"
+ "CMakeLists.txt.patch"
+ )
+sha512sums=('SKIP'
+ 'c14e14676d2c58de036df6b92876c64f60e5cdd7d9ffc822003c09d5b89b85d85defeb921258f7a96f452b2bec09367f8fc46c42b720965c10f519944fad1627'
+ )
pkgver() {
cd "$_pkgname"
@@ -29,6 +39,7 @@ prepare() {
fi
mkdir build
+ patch "$srcdir/$_pkgname/CMakeLists.txt" CMakeLists.txt.patch
}
build() {